Sie sind nicht angemeldet.

Manschy

Virtueller Landschaftsgärtner

  • »Manschy« ist der Autor dieses Themas

Beiträge: 1 450

Wohnort: Hövelhof (zwischen EDLP-Paderborn und ETUO-Gütersloh)

  • Nachricht senden

1

Sonntag, 26. Februar 2017, 22:16

FSX - Flusi stürzt während des Ladens eines Fluges ab - Verkehr scheint fehler zu sein?!?

Ach, hätte ich doch mal was anderes zu tun als dauernd an meiner Karre rumzuschrauben :banghead:

Vielleicht könnt Ihr mir ja weiterhelfen:

Während ich also auf meinem Gütersloh etliche Dinge - nennen wir es mal....designt - habe, stellte ich meinen Traffic auf 0. Das ging nun über 2 Tage.
Heute wollte ich dann mal ein paar Testflüge machen und stellte den Verkehr wie in den letzten Monaten auch auf ca. 50 Prozent. Aber Frust: Beim Laden des Fluges kam die Meldung: FSX funktioniert nicht mehr...

Folgendes kann ich als Fehlerquellen "vorberichten":

1. Es handelt sich immer um die zweite Hälfte des Ladeprozesses. Der Fehler tritt auf, wenn ich den Verkehr auf über 20 Prozent steigere - bis dahin läuft alles fluffig und schön. 21 Prozent: Absturz....
2. Ich habe in der Ereignisanzeige folgende "Application-Errors" ausfindig gemacht, die bei unterschiedlichen Ladevorgängen passierten - also NICHT gleichzeitig:
a) Pfad des fehlerhaften Moduls: FSRecorder_FSX.dll (zwei Mal), dann einige Versuche später:
b) ntdll.dll 4 Mal
c) terrain.dll 1 Mal

...während der letzten Ladevorgänge. Da es interessanterweise nicht immer die gleiche Fehlermeldung war, bin ich ratlos.

Trotz meiner Versuche, Windoof 7 nicht mehr automatisch die Updates installieren zu lassen, hat mir der Mistbock tatsächlich beim Runterfahren noch zwei Updates auf die Platte gemogelt. Ich könnte spucken....

Meine Vermutung: Irgendetwas hat mir Windows wieder untergejubelt, das hatte ich vor einigen Wochen schon einmal, konnte den Spuk aber mit einem Wiederherstellungspunkt erledigen. Nun ist das aber nicht mehr möglich gewesen.

Also meine Frage: Weiß jemand, was da in meinen DLLs rumgeistert und die unterschiedlichen Module zur Aufgabe zwingt?
Viele Grüße Manfred :winke:

Hallo, NSA: Ich fliege nur zum SPASS, von mir geht KEINE Gefahr aus! :ergeben:

Viking01

Always Check six!

Beiträge: 6 499

Wohnort: Nähe EDDK

Beruf: Steuergelderausgeber a.D.

  • Nachricht senden

2

Montag, 27. Februar 2017, 11:14

Hast Du mal versucht, die FSX.cfg zu erneuern? Die alte sichern und dann löschen oder verschieben. Dann FSX neu starten.
Viele Grüße



If in doubt mumble, if in trouble delegate!
ASUS P8Z77-V Pro, 16GB DIMM DDR3, i7-3770 OC 4,0 GHz, GTX 680 2 GB

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Manschy (27.02.2017)

Manschy

Virtueller Landschaftsgärtner

  • »Manschy« ist der Autor dieses Themas

Beiträge: 1 450

Wohnort: Hövelhof (zwischen EDLP-Paderborn und ETUO-Gütersloh)

  • Nachricht senden

3

Montag, 27. Februar 2017, 12:41

Ach Mann, immer fehlen mir bei meinen ersten Posts klare Infos. Sorry....

Ja, die FSX.cfg habe ich natürlich als erste weil einfachste Methode gecheckt, leider ohne Erfolg. Da ich ja etliche Tweaks nutze und auch den DX10 Scenery Fixer, bin ich ja von Natur aus schon immer sensibel für Eigenheiten.
Also:
FSX.cfg erneuert und auch im DX9 sowie DX10 - Modus getestet.
Mittlerweile habe ich auch diverse unter Verdacht stehende Traffic-Schergen im Scenery-Ordner außer Gefecht gesetzt, ohne Erfolg.
Aber ich werde heute Abend nochmal nach dem Ausschluss-Verfahren den Scenery-Ordner auffrischen, mal schau'n, was es bringt.
Viele Grüße Manfred :winke:

Hallo, NSA: Ich fliege nur zum SPASS, von mir geht KEINE Gefahr aus! :ergeben:

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Manschy« (27. Februar 2017, 12:41)


Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Viking01 (27.02.2017)

rolfuwe

Rolf-Uwe

Beiträge: 1 524

Wohnort: Dresden

Beruf: Rentner

  • Nachricht senden

4

Dienstag, 28. Februar 2017, 10:14

Der Fehler tritt auf, wenn ich den Verkehr auf über 20 Prozent steigere - bis dahin läuft alles fluffig und schön. 21 Prozent: Absturz....

Wieviel Traffic.BGL hast Du denn? Kann es sein das Du eine Dir anbekannte Traffic.bgl in irgendeinem Addon hast?
Bist Du 100% sicher, dass Du wirklich jeden Traffic abgeschalten kannst?

Wenn man eine fehlerauslösende Traffic.bgl ermitteln könnte u. die Flugplanzeilen mit 21% untersucht bzw. löscht, könnte das evtl. schon eine Lösung sein.
Das wäre bei meiner Traffic-Installation komplett in FSX\AddonScenery\Traffic\Themenordnern kein Problem.

Diese DLL Meldungen betreffen selten die Treiber selber. Es gibt ja viele Möglichkeiten von Fehlern, die sich dann erst in der Folge auf irgendwelche Treiber auswirken, die dann durch fehlerhafte Parameter nicht weiterarbeiten können. Da der PC schneller als die Meldungen ist, kann das dann auch mal etwas chaotisch aussehen. Ich würde mich erst mal auf die 20% Traffic konzentrieren u. überlegen welche Addons Du vor diesem Fehler installiert bzw. welche Änderungen Du vorgenommen hast.
Rolf-Uwe
unter dem Anflug EDDC 04, Dresden-Trachau

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Manschy (28.02.2017)

Manschy

Virtueller Landschaftsgärtner

  • »Manschy« ist der Autor dieses Themas

Beiträge: 1 450

Wohnort: Hövelhof (zwischen EDLP-Paderborn und ETUO-Gütersloh)

  • Nachricht senden

5

Dienstag, 28. Februar 2017, 12:14

So, nach einigen Stunden Ausschluss-Verfahren habe ich den Sieger ermittelt:

:erster: geht an eine korrupte / beschädigte AI-Traffic-Datei, die ich selber erstellt habe, die allerdings bis eben vor ein paar Tagen nie Probleme gemacht hat:

Traffic_EGVN_C130.bgl

Ich bin zwar froh wie Bolle, aber meine Frage schließt sich logischerweise gleich an:

Wie kann so etwas geschehen? Vom Zeitpunkt her waren es ein paar Updates von MS, die diesen Fehler ausgelöst haben, da bin ich absolut sicher. Können die etwas enthalten, das sich auf solch eine Datei auswirkt?
Viele Grüße Manfred :winke:

Hallo, NSA: Ich fliege nur zum SPASS, von mir geht KEINE Gefahr aus! :ergeben:

6

Dienstag, 28. Februar 2017, 17:35

naja , ohne die entpackte BGL kann man ja nur raten.
Es war aber mal ein Problem , wenn ich recht erinnere, dass einige Flightplanersteller versehentlich ihre z.Bspl. flightplans_EVGN_C130.txt mit 100% versehen hatten.

Viel wahrscheinlicher ist es jedoch, dass etwas mit der Texture der C130 etwas nicht stimmt.
Überprüf das doch mal mit ModelconverterX .

Mirtos

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Manschy (01.03.2017)

Manschy

Virtueller Landschaftsgärtner

  • »Manschy« ist der Autor dieses Themas

Beiträge: 1 450

Wohnort: Hövelhof (zwischen EDLP-Paderborn und ETUO-Gütersloh)

  • Nachricht senden

7

Mittwoch, 1. März 2017, 10:46

Danke, Mirtos. Ich glaube eher, dass ich mit der Konvertierung via "bglfpfsxconvert.exe" (ein normalerweise zuverlässiges Freeware Traffic Konvertierungsprogramm) einen Bock geschossen habe. Allerdings hat mir der AI-Flight-Planner (ein normalerweise noch zuverlässigeres Freeware Traffic Konvertierungsprogramm :rolleyes: ) auch keinen schlüssigen Hinweis auf einen Fehler gezeigt. So what? Ich lerne damit zu leben und in Zukunft nicht so schnell zu hyperventilieren :yes:
Viele Grüße Manfred :winke:

Hallo, NSA: Ich fliege nur zum SPASS, von mir geht KEINE Gefahr aus! :ergeben:

8

Sonntag, 12. März 2017, 11:12

Abstürze sollen auch durch fehlerhafte Texturen verursacht worden sein. Versuch es in deiner bgl mal mit anderen Texturen für die AI Flieger.

Griuß

Thomas
i5-3570k, GTX460, 8GB RAM, Samsung SSD 840, Sound onboard

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Manschy (12.03.2017)